Integrated Marketplace
Markets User Interface

January 3, 2014

IT Apps Markets
# Revision History

<table>
<thead>
<tr>
<th>Date or Version Number</th>
<th>Author</th>
<th>Change Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>Various</td>
<td>Initial Draft</td>
</tr>
<tr>
<td>2.0</td>
<td>Nikki Eason</td>
<td>Updated unit commitment displays; Removed Internet Explorer workarounds; Added section for filtering options</td>
</tr>
<tr>
<td>3.0</td>
<td>Nikki Eason</td>
<td>Made the following updates to reflect changes made in the Markets 1.7 release: Removed Query Mitigation Hours Updated UI location of Parameters (Hourly) and Parameters (Daily) displays Added Transaction Log Section Added Reports Section Added screenshots for the following - Query SPP Mitigated Parameters - Query Day-Ahead VRLs - Query Day-Ahead Cleared Market Transactions - Query SPP Mitigated Parameters - Query Real-Time VRLs - Query Markets Transaction Log</td>
</tr>
<tr>
<td>4.0</td>
<td>Nikki Eason</td>
<td>Made the following updates to reflect changes made in the Markets 1.8 release: Modified Submissions section (rows no longer highlight in blue when changes are made) Added screenshots for Copy functionality in Submissions section Added Historical Commitments screenshots Updated Reports section with additional XML reports available Added Wind Resource Forecast screenshots</td>
</tr>
<tr>
<td>5.0</td>
<td>Nikki Eason</td>
<td>Made the following update to reflect changes made in the Markets 1.9 release: Modified the Submissions section to include steps to copy a Day-Ahead Market Resource Offer to the Real-Time Market</td>
</tr>
</tbody>
</table>
# Table of Contents

Revision History .................................................................................................................. 1  
Table of Contents ............................................................................................................... 2  
About this Guide ............................................................................................................... 6  
  Purpose .......................................................................................................................... 6  
  Related Documents ...................................................................................................... 7  
  Terminology .................................................................................................................. 8  
Introduction ..................................................................................................................... 9  
  User Access .................................................................................................................. 9  
  Supported Browsers ...................................................................................................... 9  
  Market Timeline .......................................................................................................... 9  
  Interval Ending/Operating Hour .................................................................................... 9  
  Market Resource Offer Roll Forward Logic ................................................................. 11  
  Unit Commitment Parameters ...................................................................................... 11  
  Resource Offer Parameters .......................................................................................... 11  
User Interface .................................................................................................................. 15  
  General Layout ............................................................................................................ 15  
  Navigation .................................................................................................................... 16  
  Submissions ................................................................................................................ 16  
  Deletions ....................................................................................................................... 18  
  Filter Options .............................................................................................................. 18  
  XML Download Reports ............................................................................................... 19  
General Market Information ............................................................................................ 22  
  Query Demand Curve .................................................................................................. 22  
  Query Market Schedule Events .................................................................................... 22  
  Query Market Messages .............................................................................................. 23  
  Query Settlement Locations ........................................................................................ 23  
Energy Qualified Resources .............................................................................................. 25  
  Submit Energy JOU Ownership Share Percentages ..................................................... 25  
  Query Energy JOU Ownership Share Percentages ...................................................... 25  

Southwest Power Pool, Inc.
Submit Energy Resource Offer ................................................................. 27
Query Energy Resource Offer ............................................................... 31
Query Market Overrides ........................................................................ 36
Query SPP Mitigated Parameters .......................................................... 37

**Operating Reserve Qualified Resource** ............................................... 38
Submit Regulating Reserve Resource Offer ............................................ 38
Query Regulating Reserve Resource Offer .............................................. 40
Submit Contingency Reserve Resource Offer ....................................... 43
Query Contingency Reserve Resource Offer .......................................... 45
Query Contingency Reserve Deployments by Asset Owner ..................... 47
Query Contingency Reserve Deployments by Resource ......................... 48
Query Resource Qualification Status ..................................................... 48

**Demand Bids** .................................................................................... 50
Submit Demand Bid ................................................................................ 50
Query Demand Bid ................................................................................ 51

**Virtual Energy Bids and Offers** .......................................................... 53
Submit Virtual Bid .................................................................................. 53
Query Virtual Bid .................................................................................... 53
Submit Virtual Offer ................................................................................ 54
Query Virtual Offer ................................................................................ 54

**Reserve Zone Obligations and Requirements** ..................................... 56
Query Reserve Zone Obligations ............................................................ 56
Query Reserve Zone Requirements ......................................................... 57
Query System Wide Reserve Requirements .......................................... 58

**Load Forecast** ................................................................................... 59
Submit DRR Load Forecast .................................................................... 59
Query DRR Load Forecast ...................................................................... 59
Submit Non-Conforming Load Forecast ............................................... 60
Query Non-Conforming Load Forecast .................................................. 61

**Wind Resource Forecast** .................................................................. 62
Query Wind Resource Forecast by Resource ......................................... 62

**Resource Commitment Schedules** ..................................................... 62
Query Resource Commitment Schedules by Asset Owner ......................................................... 62
Query Resource Commitment Schedules by Resource .......................................................... 63
Query Historical Resource Commitment Schedules by Asset Owner ..................................... 63
Query Historical Resource Commitment Schedules by Resource ........................................... 64

Day-Ahead Results .................................................................................................................. 64

Query Day-Ahead Cleared Demand Bids .................................................................................. 64
Query Day-Ahead Cleared Energy Offers by Asset Owner ......................................................... 65
Query Day-Ahead Cleared Energy Offers by Resource .............................................................. 65
Query Day-Ahead Cleared OR Offers by Asset Owner .............................................................. 66
Query Day-Ahead Cleared OR Offers by Resource ................................................................. 67
Query Day-Ahead Cleared Virtual Bids ..................................................................................... 68
Query Day-Ahead Cleared Virtual Offers .................................................................................. 68
Query Day-Ahead Binding Limits ............................................................................................ 69
Query Day-Ahead LMP Summary by Settlement Location ....................................................... 69
Query Day-Ahead MCP Summary by Reserve Zone ............................................................... 70
Query Day-Ahead MW Summary ............................................................................................ 71
Query Day-Ahead VRLs ............................................................................................................ 71
Query Day-Ahead Cleared Market Transactions ..................................................................... 71

Real-Time Results ................................................................................................................ 73

Query Emergency Limits by Asset Owner .............................................................................. 73
Query Emergency Limits by Resource .................................................................................... 73
Query Real-Time Binding Limits ............................................................................................ 74
Query Real-Time Cleared Operating Reserve Offers by Asset Owner ...................................... 75
Query Real-Time Cleared Operating Reserve Offers by Resource ........................................... 75
Query Real-Time Contingency Reserve Caps by Asset Owner ................................................ 76
Query Real-Time Contingency Reserve Caps by Resource ....................................................... 77
Query Real-Time Energy Dispatch by Asset Owner ................................................................. 78
Query Real-Time Energy Dispatch by Resource ....................................................................... 78
Query Real-Time LMP Summary by Settlement Location ....................................................... 78
Query Real-Time MCP Summary by Reserve Zone ............................................................... 80
Query Real-Time Regulation Status by Asset Owner ............................................................... 81
Query Real-Time Regulation Status by Resource .................................................................... 81
<table>
<thead>
<tr>
<th>Section</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query Real-Time VRLs</td>
<td>82</td>
</tr>
<tr>
<td>Administration</td>
<td>83</td>
</tr>
<tr>
<td>XML Upload</td>
<td>83</td>
</tr>
<tr>
<td>Update XML Notification URLs</td>
<td>83</td>
</tr>
<tr>
<td>Query XML Notification URLs</td>
<td>83</td>
</tr>
<tr>
<td>Transaction Log</td>
<td>84</td>
</tr>
<tr>
<td>Query Markets Transaction Log</td>
<td>84</td>
</tr>
</tbody>
</table>
About this Guide

Purpose

The purpose of this document is to provide a Markets User Interface (UI) reference guide for Market Participants that describes how to submit bids and offers as well as view Market results. The following functional areas, presented as tabs in the UI, are described in this document.

- **Administration**: View list of transactions between SPP Markets system and Asset Owner; update XML Notification Listeners registered with SPP.
- **Demand Bids**: Submit Fixed and Price Sensitive Demand Bids and view Cleared Demand Bids.
- **Load Forecast**: Submit Mid-Term and Short-Term Non-Conforming Load Forecasts.
- **Market**: View Day-Ahead and Real-Time Balancing Markets results that are available to all Asset Owners.
- **Reserve Zone**: View Reserve Zone and System Requirements as well as Operating Reserve Obligations.
- **Virtual Energy Bids and Offers**: Submit Virtual Energy Bids and Offers as well as view Cleared Virtual Bids and Offers.

This document, along with Marketplace Protocols and Market User Interface Business Validations, fully describes the process for submitting bids and offers to the Day-Ahead and Real-Time Balancing Markets via the Markets UI.
## Related Documents

<table>
<thead>
<tr>
<th>Document</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Marketplace Portal Application Role Reference Guide</td>
<td>Defines the user roles for Marketplace user interfaces, including the Markets UI.</td>
</tr>
</tbody>
</table>
**Terminology**

The following acronyms are used in the Markets User Interface.

<table>
<thead>
<tr>
<th>Acronym</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>AO</td>
<td>Asset Owner</td>
</tr>
<tr>
<td>DA</td>
<td>Day-Ahead Market</td>
</tr>
<tr>
<td>DRR</td>
<td>Demand Response Resource</td>
</tr>
<tr>
<td>JOU</td>
<td>Joint Owned Unit</td>
</tr>
<tr>
<td>LMP</td>
<td>Locational Marginal Price</td>
</tr>
<tr>
<td>MCC</td>
<td>Marginal Congestion Component</td>
</tr>
<tr>
<td>MCP</td>
<td>Market Clearing Price</td>
</tr>
<tr>
<td>MEC</td>
<td>Marginal Energy Component</td>
</tr>
<tr>
<td>MI</td>
<td>Mitigation</td>
</tr>
<tr>
<td>MLC</td>
<td>Marginal Losses Component</td>
</tr>
<tr>
<td>MT</td>
<td>Mid-Term Non-Conforming Load Forecast</td>
</tr>
<tr>
<td>NC</td>
<td>Non-Conforming</td>
</tr>
<tr>
<td>OMS</td>
<td>Outage Management System</td>
</tr>
<tr>
<td>RN</td>
<td>Resource Name</td>
</tr>
<tr>
<td>RT</td>
<td>Real-Time Balancing Market</td>
</tr>
<tr>
<td>ST</td>
<td>Short-Term Non-Conforming Load Forecast</td>
</tr>
</tbody>
</table>
Introduction

User Access
Market Participants who want to use the Markets UI must obtain an OATI x.509 digital certificate. The user’s certificate must be registered in the Marketplace Portal by their Local Security Administrator (LSA) with the appropriate Market roles assigned. A comprehensive list of the Markets UI user roles is posted in the Marketplace Portal Application Role Reference Guide on SPP.org.

Supported Browsers
The Markets User Interface is supported on the following Internet browsers.
- Internet Explorer 8+
- Google Chrome 11+
- Firefox 7+

Market Timeline
The Integrated Marketplace timeline is specified in the Marketplace Protocols document. The specified market timeline determines when data can be submitted, viewed, and deleted.

Interval Ending/Operating Hour
The SPP Markets system uses Interval Ending notation with “5 minute Interval Ending” and “Hour Interval Ending” being the most common notations encountered. Interval is defined as a span of time that is being measured, for example, five (5) minutes, hour, or day. When referencing any time interval in the Markets system, the specific time interval is referred to by the end time in the interval. For example, for a five-minute time period: 09:00:00 – 09:05:00, the interval is referred to as Interval “0905”; for an hourly time period: 09:00:00 – 10:00:00, the interval is referred to as Hour “1000.”
The columns highlighted in the table below illustrate how Interval Ending data will be represented in the Markets User Interface.

**Note:** All time displayed in the Markets UI is in Central Prevailing Time (CPT).

<table>
<thead>
<tr>
<th>Markets Hourly Day</th>
<th>Markets 5-Minute Interval Day</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SPP Hour</strong></td>
<td><strong>Hour Interval</strong></td>
</tr>
<tr>
<td></td>
<td>Beginning</td>
</tr>
<tr>
<td></td>
<td>Ending</td>
</tr>
<tr>
<td>01</td>
<td>00:00:00</td>
</tr>
<tr>
<td>02</td>
<td>01:00:00</td>
</tr>
<tr>
<td>03</td>
<td>02:00:00</td>
</tr>
<tr>
<td>04</td>
<td>03:00:00</td>
</tr>
<tr>
<td>05</td>
<td>04:00:00</td>
</tr>
<tr>
<td>06</td>
<td>05:00:00</td>
</tr>
<tr>
<td>07</td>
<td>06:00:00</td>
</tr>
<tr>
<td>08</td>
<td>07:00:00</td>
</tr>
<tr>
<td>09</td>
<td>08:00:00</td>
</tr>
<tr>
<td>10</td>
<td>09:00:00</td>
</tr>
<tr>
<td>11</td>
<td>10:00:00</td>
</tr>
<tr>
<td>12</td>
<td>11:00:00</td>
</tr>
<tr>
<td>13</td>
<td>12:00:00</td>
</tr>
<tr>
<td>14</td>
<td>13:00:00</td>
</tr>
<tr>
<td>15</td>
<td>14:00:00</td>
</tr>
<tr>
<td>16</td>
<td>15:00:00</td>
</tr>
<tr>
<td>17</td>
<td>16:00:00</td>
</tr>
<tr>
<td>18</td>
<td>17:00:00</td>
</tr>
<tr>
<td>19</td>
<td>18:00:00</td>
</tr>
<tr>
<td>20</td>
<td>19:00:00</td>
</tr>
<tr>
<td>21</td>
<td>20:00:00</td>
</tr>
<tr>
<td>22</td>
<td>21:00:00</td>
</tr>
<tr>
<td>23</td>
<td>22:00:00</td>
</tr>
<tr>
<td>24</td>
<td>23:00:00</td>
</tr>
</tbody>
</table>
**Market Resource Offer Roll Forward Logic**

As specified in the Marketplace Protocols document, submitted Resource Offers roll forward hour to hour until changed within each respective Market (Day-Ahead and Real-Time). Offers may be submitted that differ for each hour of the Operating Day, except for those parameters related to unit commitment for which a single value is submitted that rolls forward in each hour until updated. The unit commitment parameters are outlined in the Marketplace Protocols.

**Unit Commitment Parameters**

The unit commitment parameters are daily values. The Markets system will use the single daily value in each hour of the Operating Day until changed. Below is an example of how unit commitment parameters roll forward in a typical Operating Day.

<table>
<thead>
<tr>
<th>Operating Hour</th>
<th>01</th>
<th>02</th>
<th>03</th>
<th>...</th>
<th>23</th>
<th>24</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum Daily Starts</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Maximum Weekly Starts</td>
<td>3</td>
<td>3</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
</tr>
</tbody>
</table>

In this example, the Participant initially enters a Maximum Daily Starts = 1 and a Maximum Weekly Starts = 3 for the Operating Day. Prior to hour ending 03, the Participant changes the Maximum Weekly Starts from 3 to 4. This new value (4) will now be used for each subsequent hour until changed.

**Resource Offer Parameters**

Resource Offer parameters not specified as unit commitment roll forward hour to hour until changed. For example, an operating limit submitted for hour ending 04 of the current Operating Day will be used for subsequent hour ending 04 until modified.

Below is an example of how Resource Offer parameters roll forward from a typical Operating Day.
In the example above, the participant made changes to hour ending 01, 22, and 23 between Operating Day 1 and Operating Day 2, as well as hour ending 01 between Operating Day 2 and Operating Day 3. In this scenario, the values submitted for Operating Day 1 hours ending 02 – 21 and 24 will roll forward to Operating Day 2. For Operating Day 3, all hours used in Operating Day 2 will roll forward, except for hour ending 01 which was updated.

**Fall Transition**

During the fall transition from Daylight Saving Time (DST), Operating Hour 02 is repeated. Below is an example of how Resource Offer parameters roll forward during this transition.
Note: The duplicate hour is represented in this table as 02*. This is consistent with how the duplicate hour will be presented in the Markets UI.

<table>
<thead>
<tr>
<th>Operating Hour</th>
<th>Resource Offer Day Before Fall DST</th>
<th>Resource Offer Day of Fall DST</th>
<th>Resource Offer Day After Fall DST</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>25</td>
<td>20</td>
<td>25</td>
</tr>
<tr>
<td>02</td>
<td>25</td>
<td>25</td>
<td>20</td>
</tr>
<tr>
<td>02*</td>
<td></td>
<td>20</td>
<td></td>
</tr>
<tr>
<td>03</td>
<td>25</td>
<td>25</td>
<td>25</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>22</td>
<td>25</td>
<td>15</td>
<td>15</td>
</tr>
<tr>
<td>23</td>
<td>25</td>
<td>15</td>
<td>15</td>
</tr>
<tr>
<td>24</td>
<td>25</td>
<td>25</td>
<td>25</td>
</tr>
</tbody>
</table>

Roll Forward
Participant Update Applied

In this example, the participant submitted a different limit for the duplicate hour of fall DST, but did not submit an update for the second Operating Hour of the day following DST. Therefore, the Markets system will roll forward the value submitted for the duplicate hour (02*) on DST for use in subsequent hour ending 02 until changed. If the offer parameter used in the duplicate hour is not the correct value that should be used for future offers, participants must submit an update to the Markets system for the next Operating Day.

Spring Transition
On the spring transition day to Daylight Saving Time, Operating Hour 02 is skipped. The following illustrates how the Resource Offer parameters roll forward during the spring DST transition.
In this scenario, no updates were made by the participant to hour ending 02 for the day after spring transition. Therefore, the data used in hour ending 02 on the day prior to the spring transition to DST will roll forward for hour ending 02 until updated.
User Interface

General Layout

The following illustrates the general layout of each Functional tab in the Markets UI.

1 – Screen Name and Time: Screen Name associated with user certificate and local time from user’s computer.
2 – Functional tabs: Each tab represents a different set of displays. Access to each tab is dependent on roles assigned by the user’s LSA.
3 – Navigation Tree: Presents the user with Asset Owner specific options for each Functional tab.
4 – Filter Options: Filtering options differ per Functional tab.
5 – Content: Displays view or edit page based on selection in Navigation Tree.
6 – Messages: Confirmation status associated with each user action performed in the UI. The Message bar will display green when the action is successful and red in the case of errors.
7 – Expand/Collapse Navigation Tree: User can expand or collapse the Navigation Tree by clicking this button.
Navigation

To navigate in the UI, perform the following repeatable steps.

1. Select Functional tab
2. Select Asset Owner Name
3. Select Operating Day

Submissions

After selecting **Edit** in the Navigation tree, the user is presented with an editable page in the Content window. All editable fields are displayed as a drop-down list or cell blocks.

In the example below, fields outlined in red are editable.

To submit data to the Markets system, perform the following steps.
1. Enter information in all applicable fields.
2. Prior to saving changes, verify that all cells highlighted in yellow include the wanted modifications.
   - Once the **Save** button is clicked, all cells in yellow are submitted to the Markets system for validation.

In the example below, the fields in yellow for Hour 01 and Hour 04 will be submitted to the Markets system for validation, and saved if no errors are found.
Copy Data

To copy data from one hour to other hours within the same page, perform the following steps.

1. Select the checkbox beside the hour to be copied.
2. Select the **Copy** button.
3. Select the checkbox beside the hour or hours to copy the information to for submission.
4. Select the **Paste** button.
5. Prior to saving changes, verify that all cells highlighted in yellow include the wanted modifications.
6. Select the **Save** button to submit the updates to the Markets system for validation.

Copy Day-Ahead Market Resource Offer to Real-Time Market Resource Offer

To copy a Day-Ahead Market Resource Offer to the Real-Time Market, perform the following steps.

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select the appropriate Resource.
6. Select the appropriate Day-Ahead Market Resource Offer page (e.g. Parameters (Hourly)) to be copied to the Real-Time Market.
7. Select **Edit > DA**.
8. Select the **Save to RTBM** button.
    - **Save to RTBM** will copy everything on the selected page to the Real-Time Market for the same Operating Day.

**Important:** Hourly Day-Ahead Market Resource Offers may be copied to the Real-Time Market up to 30 minutes prior to the start of the Real-Time Market Operating Day (11:30PM CPT prior to the selected Operating Day).
Deletions

The ability to delete submitted data is only available for the following items.

- Demand Bids
- DRR Load Forecast
- Non-Conforming Load Forecast
- Virtual Energy Bids
- Virtual Energy Offers

To delete data, select **Edit** on the appropriate option in the Navigation tree. Once the page is loaded in the Content window, select the checkbox for each Interval to be deleted. To select all Intervals, select the checkbox in the header. After selecting the intervals to be deleted, click **Delete**.

**Important:** Once the **Delete** button is clicked, the request to delete data cannot be cancelled.

Filter Options

On each Functional tab, there are filters available to customize the options presented in the Navigation tree. To apply a filter, perform the following steps.

1. Select the desired filter preferences
2. Click **Apply**

**Important:** The filter options are automatically reset to the system defaults once the user navigates to a different Functional tab in the UI.

The table below describes the filter options available.

<table>
<thead>
<tr>
<th>Functional tab</th>
<th>Filter Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Days Before Today</td>
<td>Adjust the slider to indicate the number of Operating Days prior to today to display.</td>
</tr>
<tr>
<td>All</td>
<td>Days After Today</td>
<td>Adjust the slider to indicate the number of Operating Days after to today to display.</td>
</tr>
<tr>
<td>Administration</td>
<td>(Functionality is not yet implemented in the UI)</td>
<td></td>
</tr>
<tr>
<td>Demand Bids</td>
<td>Find Locations</td>
<td>Enter the location names to be displayed in the</td>
</tr>
</tbody>
</table>
**Navigation tree**

| Demand Bids | Show Locations – With Fixed | Display all locations with a Fixed Bid |
| Demand Bids | Show Locations – With Price Sensitive | Display all locations with a Price Sensitive Bid |
| Resource Offers | Find Resources | Enter the resource names to be displayed in the Navigation tree |
| Resource Offers | Qualifications – Energy | Display all Energy qualified resources |
| Resource Offers | Qualifications – Regulation | Display all Regulation qualified resources |
| Resource Offers | Qualifications – Spinning | Display all Spinning qualified resources |
| Resource Offers | Qualifications – Supplemental | Display all Supplemental qualified resources |
| Resource Offers | Resource Types – Blocked Demand Resource | Displays all BDRs |
| Resource Offers | Resource Types – Dispatchable Demand Resource | Displays all DDRs |
| Resource Offers | Resource Types – Dispatchable Variable Energy Resource | Displays all DVERs |
| Resource Offers | Resource Types – External Demand Resource | Displays all EDRs |
| Resource Offers | Resource Types – Generator | Displays all generators |
| Resource Offers | Resource Types – Non-Dispatchable Variable Energy Resource | Displays all NDVERs |
| Resource Offers | Resource Types – Plant | Displays all plants |
| Virtual Energy Bids and Offers | Find Locations | Enter the location names to be displayed in the Navigation tree |
| Virtual Energy Bids and Offers | Show Locations – With Bids | Display all locations with a Virtual Bid |
| Virtual Energy Bids and Offers | Show Locations – With Offers | Display all locations with a Virtual Offer |

**XML Download Reports**

On each Functional tab under the Operating Day, there is a Reports page in the Navigation tree which provides links to download XML reports. The XML reports will be in the same format as the “ByDay” operations defined in the Marketplace Markets Web Services XSDs published on SPP.org.

The table below outlines the XML reports available as well as the corresponding API operations from the Markets Web Services.

<table>
<thead>
<tr>
<th>Functional tab</th>
<th>Report</th>
<th>Markets API Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Demand Bids</td>
<td>Cleared Fixed Bids</td>
<td>GetDemandClearedFixedBidSetByDay</td>
</tr>
<tr>
<td>Demand Bids</td>
<td>Cleared Price Sensitive Bids</td>
<td>GetDemandClearedPriceSensitiveBidSetByDay</td>
</tr>
<tr>
<td>Demand Bids</td>
<td>Fixed Bids</td>
<td>GetDemandFixedBidSetByDay</td>
</tr>
<tr>
<td>Demand Bids</td>
<td>Price Sensitive Bids</td>
<td>GetDemandPriceSensitiveBidSetByDay</td>
</tr>
<tr>
<td>Load Forecast</td>
<td>Mid-Term</td>
<td>GetLoadforecastSetByDay</td>
</tr>
<tr>
<td>Load Forecast</td>
<td>Short-Term</td>
<td>GetLoadforecastSetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>DAMKT Binding Limits</td>
<td>GetMarketBindingLimitSetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>RTBM Binding Limits</td>
<td>GetMarketBindingLimitByIntervalSetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>Demand Curve – Operating Reserve</td>
<td>GetMarketDemandCurveSetByDay</td>
</tr>
<tr>
<td>Category</td>
<td>Description</td>
<td>Function</td>
</tr>
<tr>
<td>------------------------------</td>
<td>--------------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Market</td>
<td>Demand Curve – Regulation Down</td>
<td>GetMarketDemandCurveSetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>Demand Curve – Regulation Up</td>
<td>GetMarketDemandCurveSetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>DAMKT LMP Summary</td>
<td>GetMarketLMPSummarySetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>RTBM LMP Summary (Not yet implemented)</td>
<td></td>
</tr>
<tr>
<td>Market</td>
<td>DAMKT MCP Summary</td>
<td>GetMarketMCPSummarySetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>RTBM MCP Summary</td>
<td>GetMarketMCPSummaryByIntervalSetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>Messages</td>
<td>GetMarketMessageSetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>MW Summary</td>
<td>GetMarketMWSummarySetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>Nodes</td>
<td>GetMarketNodeSetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>Timeline Events</td>
<td>GetMarketTimelineEventSetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>DAMKT VRL</td>
<td>GetMarketVRLSetByDay</td>
</tr>
<tr>
<td>Market</td>
<td>RTBM VRL</td>
<td>GetMarketVRLByIntervalSetByDay</td>
</tr>
<tr>
<td>Reserve Zone</td>
<td>Obligations</td>
<td>GetReserveObligationSetByDay</td>
</tr>
<tr>
<td>Reserve Zone</td>
<td>System Requirements</td>
<td>GetReserveSystemRequirementSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Cleared Offers</td>
<td>GetEnergyClearedOfferSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Cleared Transactions</td>
<td>GetEnergyClearedTransactionSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Commitment History</td>
<td>GetEnergyCommitmentHistorySetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Commitments</td>
<td>GetEnergyCommitmentSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Commitment Status Conflicts – DAMKT</td>
<td>GetEnergyCommitmentStatusConflictSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Commitment Status Conflicts – RTBM</td>
<td>GetEnergyDispatchSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Dispatches</td>
<td></td>
</tr>
<tr>
<td>Resource Offers</td>
<td>DRR Load Forecasts</td>
<td>GetEnergyDRRLoadForecastSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>EDR Resource Offers – DAMKT</td>
<td>GetEnergyEDRResourceOfferSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>EDR Resource Offers - RTBM</td>
<td>GetEnergyEDRResourceOfferSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Emergency Limit Disabled</td>
<td>GetEnergyEmergencyLimitDisabledSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>JOU Ownership Shares</td>
<td>GetEnergyJOUOwnershipShareSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Mitigated Parameters</td>
<td>GetEnergyMitigatedParameterSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Overrides</td>
<td>GetEnergyOverrideSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Qualification Status</td>
<td>GetEnergyQualificationStatusSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Commitments</td>
<td>GetEnergyCommitmentSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Resource Offers - DAMKT</td>
<td>GetEnergyResourceOfferSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Resource Offers - RTBM</td>
<td>GetEnergyResourceOfferSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Wind Resource Forecasts</td>
<td>GetEnergyWindResourceForecastSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Reserve Caps</td>
<td>GetReserveCapSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Reserve Cleared Offers</td>
<td>GetReserveClearedOfferSetByDay</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>CR Deployments</td>
<td>GetReserveCRDeploymentSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Reserve Dispatches</td>
<td>GetReserveDispatchSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Reserve EDR Resource Offers – DAMKT</td>
<td>GetReserveEDRResourceOfferSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Reserve EDR Resource Offers – RTBM</td>
<td>GetReserveEDRResourceOfferSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Reserve Mitigated Parameters</td>
<td>GetReserveMitigatedParameterSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Reserve Regulation Status</td>
<td>GetReserveRegulationStatusSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Reserve Resource Offers – DAMKT</td>
<td>GetReserveResourceOfferSetByDay</td>
</tr>
<tr>
<td>Resource Offers</td>
<td>Reserve Resource Offers – RTBM</td>
<td>GetReserveResourceOfferSetByDay</td>
</tr>
<tr>
<td>Virtual Energy Bids and Offers</td>
<td>Bids</td>
<td>GetVirtualBidSetByDay</td>
</tr>
<tr>
<td>Virtual Energy Bids and Offers</td>
<td>Cleared Bids</td>
<td>GetVirtualClearedBidSetByDay</td>
</tr>
<tr>
<td>Virtual Energy Bids and Offers</td>
<td>Offers</td>
<td>GetVirtualOfferSetByDay</td>
</tr>
<tr>
<td>Virtual Energy Bids and Offers</td>
<td>Cleared Offers</td>
<td>GetVirtualClearedOfferSetByDay</td>
</tr>
</tbody>
</table>

To download a report, select the appropriate link which will begin the download process.
General Market Information

Query Demand Curve

To query a Demand Curve:

1. Select the Market tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select General.
5. Select Demand Curve.
6. Choose one of the three types of products, and select View.
7. Regardless of product chosen, the same formatted screen will display.

Query Market Schedule Events

To query Market Schedule Events:

1. Select the Market tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select General.
5. Choose Timeline Events, and select View.
Query Market Messages

To query Market Messages:

1. Select the **Market** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **General**.
5. Choose **Messages**, and select **View**.

Query Settlement Locations

To query Settlement Locations:

1. Select **Market** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **General**.
5. Select **Settlement Locations**.
6. Choose **View**.
Energy Qualified Resources

Submit Energy JOU Ownership Share Percentages

To submit an Energy JOU Ownership Share Percentages:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select the appropriate Resource.
7. Choose Share Ownership and select Edit.
8. Select the check box for the Location(s) that you want to edit, and update the Share Percentage.
9. Click Save to submit.

Query Energy JOU Ownership Share Percentages

To query Energy JOU Ownership Share Percentages:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select the appropriate Resource.
7. Choose Share Ownership, and select View.
Navigating through the Integrated Marketplace Markets User Interface Guide, you can see a snapshot of the interface showing the navigation options and some data entries. The interface includes tabs for Administrators, Demand Sides, Load Forecast, Market, Reserve Zone, Resource Offers, Virtual Energy Sides, and Offers.

The navigation section displays a hierarchy of options, including '2013-03-05', 'Resources', 'RN', 'RN', 'RN', 'RN', 'RN', 'RN', 'RN'. Below this hierarchy, there are options for 'Characteristics', 'Mitigation', 'Qualification Status', 'Share Documentation', and 'Edit'.

In the data section, there are columns labeled 'Locality', 'Asset Owner', and 'Share Percentage'. Two rows are visible, each with a locality of '8X', an asset owner of 'A0', and share percentages of '56' and '50', respectively.
Submit Energy Resource Offer

To submit an Energy Resource Offer:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select the appropriate Resource.
6. Choose **Parameters (Daily)**, and select **Edit > DA, MI, or RT**.
   a. Selecting **DA** and **RT** returns a table with daily parameters for the Resource selected.
   b. Select the check box and update the daily unit parameters.
   c. Click **Save** to submit.
   d. Selecting **MI** returns a table with mitigation data.
   e. Select the check box and update daily cost parameters.
   f. Click **Save** to submit.
7. Choose **Parameters (Hourly)**, and select **Edit > DA or RT**.
   a. Selecting **DA** and **RT** returns a table with hourly parameters for the Resource selected.
   b. Select the check box for the Hour(s) you want to edit, and update.
   c. Click **Save** to submit.

d. Selecting **MI** returns a table with mitigation data.
e. Select the check box for the Hour(s) you want to edit, and update.
f. Click **Save** to submit.
9. Choose Curve, and select Edit > DA, MI, or RT.
   a. Selecting DA, MI, or RT returns a table with the applicable Price Curves by Hour.
   b. Select the check box for the Hour(s) that you want to edit, and update the Price Curve.
   c. Click Save to submit.
10. Choose **Ramp Rate Down**, and select **Edit > DA or RT**.
   a. Selecting DA and RT returns a table with hourly Ramp Rate Down curves for the Resource selected.
   b. Select the check box for the Hour(s) you want to edit, and update.
   c. Click **Save** to submit.

11. Choose **Ramp Rate Up**, and select **Edit > DA or RT**.
   a. Selecting DA and RT returns a table with hourly Ramp Rate Up curves for the Resource selected.
   b. Select the check box for the Hour(s) you want to edit, and update.
   c. Click **Save** to submit.
Query Energy Resource Offer

To query an Energy Resource Offer:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select the appropriate Resource.
6. Choose **Parameters (Daily)**, and select View > DA, MI, or RT.
   a. Selecting **DA** and **RT** returns a table with hourly parameters for the Resource selected.
   b. Selecting **MI** returns a table with mitigation data.
7. Choose **Parameters (Hourly)**, and select **View > DA, MI, or RT**.
   a. Selecting **DA** and **RT** returns a table with hourly parameters for the Resource selected.
b. Selecting MI returns a table with mitigation data.

9. Choose Curve, and select View > DA, MI, or RT.

10. Choose Ramp Rate Down, and select View > DA or RT.
    a. Selecting DA and RT returns a table with hourly Ramp Rate Down curves for the Resource selected.
<table>
<thead>
<tr>
<th>Hour</th>
<th>Zone Rate (MW/Min)</th>
<th>Segment 1</th>
<th>Segment 2</th>
<th>Segment 3</th>
<th>Segment 4</th>
<th>Segment 5</th>
<th>Segment 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>MW Normal Rate</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Emer Rate</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>02</td>
<td>MW Normal Rate</td>
<td>0</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Emer Rate</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>03</td>
<td>MW Normal Rate</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Emer Rate</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>04</td>
<td>MW Normal Rate</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Emer Rate</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>05</td>
<td>MW Normal Rate</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Emer Rate</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Navigation**

- Resources
  - Load
  - Generation
  - Markets
    - Market Results
      - Resources
        - Resources
          - Load
          - Generation
          - Markets
            - Market Results
              - Resources
                - Load
                - Generation
                - Markets
11. Choose **Ramp Rate Up**, and select **View > DA or RT**.

   a. Selecting **DA** and **RT** returns a table with hourly Ramp Rate Up curves for the Resource selected.
Query Market Overrides

To query Market Overrides:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select the appropriate Resource.
6. Select **Real Time Results**.
7. Choose **Overrides**, and select **View**.

![Market User Interface Screenshot](image-url)
Query SPP Mitigated Parameters

To query SPP Mitigated Parameters:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select the appropriate Resource.
7. Choose Parameters, and select View.
8. Choose Ramp Rates, and select View.
Submit Regulating Reserve Resource Offer

To submit a Regulating Reserve Resource Offer:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select the appropriate Resource.
6. Select **Regulating Reserve Offer**.
7. Choose **Ramp Rate**, and select Edit > DA or RT
   a. Selecting DA or RT returns a table with Ramp Rate information by hour.
   b. Select the check box for the Hour(s) that you want to edit, and update the Ramp Rate and MW.
   c. Click **Save** to submit.

8. Choose **Regulation Down**, and select Edit > DA, MI or RT.
   a. Selecting DA or RT returns a table with Regulation Down offers by hour.
   b. Select the check box for the Hour(s) that you want to edit, and update.
   c. Click **Save** to submit.
d. Selecting MI returns a table with Mitigation offers.

e. Select the Check box for the Hour(s) you want to edit, and update.

e. Click Save to submit.

9. Choose Regulation Up, and select Edit > DA, MI or RT.

a. Selecting DA or RT returns a table with Regulation Up offers by hour.

b. Select the check box for the Hour(s) that you want to edit, and update.

c. Click Save to submit.
d. Selecting **MI** returns a table with Mitigation data.

e. Select the Check box for the Hour(s) you want to edit, and update.

f. Click **Save** to submit.

---

**Query Regulating Reserve Resource Offer**

To query a Regulating Reserve Resource Offer:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select the appropriate Resource.
6. Select **Regulating Reserve Offer**.
7. Choose **Ramp Rate**, and select **View > DA or RT**.
   a. Selecting **DA** or **RT** returns a table with Ramp Rate information by hour.

8. Choose **Regulation Down**, and select **View > DA, MI or RT**.
   a. Selecting **DA** or **RT** returns a table with Regulation Up offers by hour.
   b. Selecting **MI** returns a table with Regulation Down, Mitigation offers.
9. Choose Regulation Up, and select View > DA, MI or RT.
   a. Selecting DA or RT returns a table with Regulation Down offers by hour.

   ![Market User Interface](image)

   b. Selecting MI returns a table with Regulation Up, Mitigation offers.

   ![Market User Interface](image)
Submit Contingency Reserve Resource Offer

To submit a Contingency Reserve Resource Offer:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select the appropriate Resource.
6. Select Contingency Reserve Offer.
7. Choose Ramp Rate, and select Edit > DA or RT.
   a. Selecting DA or RT returns a table with Contingency Reserve Offer, Ramp Rate information by hour.
   b. Select the check box for the Hour(s) that you want to edit, and update.
   c. Click Save to submit.
8. Choose **Spinning**, and select **Edit > DA, MI or RT**.
   a. Selecting **DA** or **RT** returns a table with Contingency Reserve Offer, Spinning offers by hour.
   b. Select the check box for the Hour(s) that you want to edit, and update.
   c. Click **Save** to submit.
   d. Selecting **MI** returns a table with Mitigation offers.
   e. Select the check box for the Hour(s) that you want to edit, and update.
   f. Click **Save** to submit.

9. Choose **Supplemental**, and select **Edit > DA, MI or RT**.
   a. Selecting **DA** or **RT** returns a table with Contingency Reserve Offer, Supplemental offers by hour.
   b. Select the check box for the Hour(s) that you want to edit, and update.
   c. Click **Save** to submit.
d. Selecting **MI** returns a table with Mitigation offers.
e. Select the Check box for the Hour(s) you want to edit, and update.
f. Click **Save** to submit.

---

**Query Contingency Reserve Resource Offer**

To query a Contingency Reserve Resource Offer:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select the appropriate Resource.
6. Select **Contingency Reserve Offer**.
7. Choose **Ramp Rate**, and select **View > DA or RT**.
8. Choose **Spinning**, and select **View > DA, MI, or RT**.

   a. Selecting **DA** or **RT** returns a table with Contingency Reserve Offer, Spinning offers by hour.

   b. Selecting **MI** returns a table with Mitigation offers.
9. Choose **Supplemental**, and select **View > DA, MI, or RT**.
   a. Selecting **DA** or **RT** returns a table with Contingency Reserve Offer, Supplemental offers by hour.

   ![Image of Market User Interface showing Contingency Reserve Offers]

   b. Selecting **MI** returns a table with Mitigation offers.

   ![Image of Market User Interface showing Mitigation Offers]

**Query Contingency Reserve Deployments by Asset Owner**

To query a Contingency Reserve Deployments by Asset Owner:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Market Results**.
5. Choose **Contingency Reserve Deployment**, and select **View**.
Query Contingency Reserve Deployments by Resource

To query a Contingency Reserve Deployments by Resource:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select the appropriate Resource.
6. Select **Real Time Results**.
7. Choose **Contingency Reserve Deployment**, and select **View**.

Query Resource Qualification Status

To query Resource Qualification Status:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select the appropriate Resource.
7. Choose Qualification Status, and select View.
Demand Bids

Submit Demand Bid

To submit a Fixed Demand Bid:

1. Select the Demand Bid tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Bid Locations.
5. Select a location.
6. Choose Fixed, and select Edit.
   a. Select the check box for the Hour(s) that you want to edit.
   b. Click Save to submit.

To submit a Price Sensitive Demand Bid:

1. Select the Demand Bid tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Bid Locations.
5. Select a location.
   a. Select the check box for the Hour(s) that you want to edit.
   b. Click Save to submit.
Query Demand Bid

To query Fixed Demand Bid:

1. Select the Demand Bid tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Bid Locations.
5. Select a location.
6. Choose Fixed, and select View.

To query Price Sensitive Demand Bid:

1. Select the Demand Bid tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Bid Locations.
5. Select a resource.
6. Choose Price Sensitive, and select View.
<table>
<thead>
<tr>
<th>Hour</th>
<th>Use Slope</th>
<th>Price</th>
<th>Price</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>Yes</td>
<td>$40.4000</td>
<td>$27.4700</td>
<td>$20.4100</td>
</tr>
<tr>
<td>02</td>
<td>Yes</td>
<td>$40.4000</td>
<td>$27.4700</td>
<td>$20.4100</td>
</tr>
<tr>
<td>03</td>
<td>Yes</td>
<td>$40.4000</td>
<td>$27.4700</td>
<td>$20.4100</td>
</tr>
<tr>
<td>04</td>
<td>Yes</td>
<td>$40.4000</td>
<td>$27.4700</td>
<td>$20.4100</td>
</tr>
</tbody>
</table>
Virtual Energy Bids and Offers

Submit Virtual Bid

To submit a Virtual Bid:

1. Select the Virtual Energy Bids and Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Locations.
5. Select a location.
6. Choose Virtual Bids, and select Edit.
   a. Select the check box for the Hour(s) that you want to edit.
   b. Click Save to submit.

Query Virtual Bid

To query a Virtual Bid:

1. Select the Virtual Energy Bids and Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Locations.
5. Select a location.
6. Choose Virtual Bids, and select View.
Submit Virtual Offer

To submit a Virtual Offer:

1. Select the Virtual Energy Bids and Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Locations.
5. Select a location.
6. Choose Virtual Offer, and select Edit.
   a. Select the check box for the Hour(s) that you want to edit.
   b. Click Save to submit.

Query Virtual Offer

To query a Virtual Offer:

1. Select the Virtual Energy Bids and Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Locations.
5. Select a location.
6. Choose **Virtual Offer**, and select **View**.
Reserve Zone Obligations and Requirements

Query Reserve Zone Obligations

To query Reserve Zone Obligations:

1. Select the Reserve Zone tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select a reserve zone.
5. Select Obligations.
6. Choose Regulation Down, and select View.

7. Choose Regulation Up, and select View.

8. Choose Spinning, and select View.
9. Choose **Supplemental**, and select **View**.

**Query Reserve Zone Requirements**

To query Reserve Zone Requirements:

1. Select the **Reserve Zone** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select a reserve zone.
5. Choose **Requirements**, and select **View**.
Query System Wide Reserve Requirements

To query System Wide Reserve Zone Requirements:

1. Select the Reserve Zone tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select SPP.
5. Choose Requirements, and select View.
Load Forecast

Submit DRR Load Forecast

To submit a DRR Load Forecast:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select the appropriate Resource.
7. Choose DRR Load Forecast, and select Edit.
8. Select the check box for the hour(s) that you want to edit, and update the MWs.
9. Click Save to submit.

Query DRR Load Forecast

To query a DRR Load Forecast:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select the appropriate Resource.
7. Select **DRR Load Forecast**.
8. Choose DRR Load Forecast, and select **View**.

---

**Submit Non-Conforming Load Forecast**

To submit a Non-Conforming Load Forecast:

1. Select the **Load Forecast** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select the **NC Load Names**.
5. Choose the appropriate Resource, and select **Edit > MT** or **ST**.
   a. Selecting **MT** returns a table with MW intervals of one hour.
   b. Select the check box for the hour(s) that you want to edit, and update the MWs.
   c. Click **Save** to submit.
d. Selecting ST returns a table with MW intervals of fifteen minutes.
e. Select the check box for the hour(s) that you want to edit, and update the MWs.
f. Click Save to submit.

Query Non-Conforming Load Forecast

To query a Non-Conforming Load Forecast:

1. Select the Load Forecast tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select the NC Load Names.
5. Choose the appropriate Resource, and select View > MT or ST.
   a. Selecting MT returns a table with hourly intervals.
   
   b. Selecting ST returns a table with 15 minute intervals.
Wind Resource Forecast

Query Wind Resource Forecast by Resource

To view Resource Commitment Schedules by Resource:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select a resource.

Resource Commitment Schedules

Query Resource Commitment Schedules by Asset Owner

To view Resource Commitment Schedules by Asset Owner:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Market Results.
5. Choose Commitments, and select View.
Query Resource Commitment Schedules by Resource

To view Resource Commitment Schedules by Resource:

7. Select the **Resource Offers** tab.
8. In the Navigation tree, select the appropriate Asset Owner.
9. Select a date.
10. Select **Resources**.
11. Select a resource.
12. Choose **Commitment**, and select **View**.

Query Historical Resource Commitment Schedules by Asset Owner

To view Historical Resource Commitment Schedules by Asset Owner:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Market Results**.
5. Choose **Commitment History**, and select **View**.
Query Historical Resource Commitment Schedules by Resource

To view Historical Resource Commitment Schedules by Resource:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select a resource.
6. Choose Commitment History, and select View.

Day-Ahead Results

Query Day-Ahead Cleared Demand Bids

To view Day-Ahead Cleared Demand Bids:

1. Select the Demand Bids tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Cleared Bids.
5. Choose the type of bid, and select **View**

**Query Day-Ahead Cleared Energy Offers by Asset Owner**

To view Day-Ahead Cleared Energy Offers for all resources associated with an Asset Owner:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Market Results**.
5. Select **Day Ahead Cleared Offers**.
6. Select **Energy** and click **View**.

**Query Day-Ahead Cleared Energy Offers by Resource**

To view Day-Ahead Cleared Energy Offers for a particular resource:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select a resource.
6. Select **Day-Ahead Results**.
7. Select **Energy** and click **View**.

**Query Day-Ahead Cleared OR Offers by Asset Owner**

To view Day-Ahead Cleared OR Offers for all resources associated with an Asset Owner:

1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Market Results**.
5. Select **Day Ahead Cleared Offers**.
6. Choose **Regulation Down**, and select **View**.
   - or -
7. Choose **Regulation Up**, and select **View**.
   - or -
8. Choose **Spinning**, and select **View**.
   - or -
9. Choose **Supplemental**, and select **View**.
Query Day-Ahead Cleared OR Offers by Resource

To view Day-Ahead Cleared OR Offers for a particular resource:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select a resource.
6. Select Day Ahead Results.
7. Choose Regulation Down, and select View.
   -Or-
8. Choose Regulation Up, and select View.
   -Or-
9. Choose Spinning, and select View.
   -Or-
10. Choose Supplemental, and select View.
Query Day-Ahead Cleared Virtual Bids

To view Day-Ahead Cleared Virtual Bids:

1. Select the Virtual Energy Bids and Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Cleared.
5. Choose Bids, and select View.

Query Day-Ahead Cleared Virtual Offers

To view Day-Ahead Cleared Virtual Offers:
1. Select the **Virtual Energy Bids and Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Cleared**.
5. Choose **Offers**, and select **View**.

![Virtual Energy Bids and Offers](image.png)

**Query Day-Ahead Binding Limits**

To view Day-Ahead Binding Limits:

1. Select the **Market** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Day-Ahead Market**.
5. Choose **Binding Limits**, and select **View**.

![Day-Ahead Binding Limits](image.png)

**Query Day-Ahead LMP Summary by Settlement Location**

To view a Day-Ahead LMP Summary by Settlement Location:
1. Select the **Market** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Day-Ahead Market**.
5. Select **LMP Summary**.
6. Choose an hour, and select **View**.

**Query Day-Ahead MCP Summary by Reserve Zone**

To view a Day-Ahead MCP Summary by Reserve Zone:

1. Select the **Market** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Day-Ahead Market**.
5. Select **MCP Summary**.
6. Choose an hour, and select **View**.
Query Day-Ahead MW Summary

To view a Day-Ahead MW Summary:

1. Select the Market tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
5. Choose MW Summary, and select View.

Query Day-Ahead VRLs

To view Day-Ahead VRLs:

1. Select the Market tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
5. Choose Violation Relaxation Limits, and select View.

Query Day-Ahead Cleared Market Transactions

To view Day-Ahead Cleared Market Transactions:

1. Select the Energy tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Market Results**.
5. Select **Day Ahead Cleared Transactions**.
6. Choose an hour, and select **View**.
Real-Time Results

Query Emergency Limits by Asset Owner

To view Emergency Limits by Asset Owner:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Market Results.
5. Choose Emergency Limits, and select View.

Query Emergency Limits by Resource

To view Emergency Limits by Resource:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select a resource.
6. Select Real Time Results.
7. Choose Emergency Limit, and select View.
Query Real-Time Binding Limits

To view Real-Time Binding Limits:

1. Select the Market tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
5. Select Binding Limits.
6. Select an hour.
7. Choose an interval, and select View.
Query Real-Time Cleared Operating Reserve Offers by Asset Owner

To view Real-Time Cleared OR Offers by Asset Owner:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Market Results.
5. Select Real Time Dispatch.
7. Choose an hour, and select View.
   -or-
10. Select Regulation Up.
11. Choose an hour, and select View.
   -or-
12. Select Spinning.
13. Choose an hour, and select View.
   -or-
14. Select Supplemental.
15. Choose an hour, and select View.
Query Real-Time Cleared Operating Reserve Offers by Resource

To view Real-Time Cleared OR Offers by Resource:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select a resource.
6. Select Real Time Results.
7. Select Dispatch.
8. Select Regulation Down.
9. Choose an hour, and select View.
    - or -
10. Select Regulation Up.
11. Choose an hour, and select View.
    - or -
12. Select Spinning.
13. Choose an hour, and select View.
    - or -
14. Select Supplemental.
15. Choose an hour, and select View.
To view Real-Time Contingency Reserve Caps by Asset Owner:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Market Results.
5. Choose Reserve Cap, and select View.

To view Real-Time Contingency Reserve Caps by Resource:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select a resource.
6. Select Real Time Results.
7. Choose Reserve Cap, and select View.
Query Real-Time Energy Dispatch by Asset Owner

To view Real-Time Energy Dispatch by Asset Owner:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Market Results.
5. Select Real Time Dispatch.
7. Choose an hour, and select View.

Query Real-Time Energy Dispatch by Resource

To view Real-Time Energy Dispatch by Resource:
1. Select the **Resource Offers** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Resources**.
5. Select a resource.
6. Select **Real Time Results**.
7. Select **Dispatch**.
8. Select **Energy**.
9. Choose an hour, and select **View**.

![Image of the user interface](image)

**Query Real-Time LMP Summary by Settlement Location**

To view Real-Time LMP Summary by Settlement Location:

1. Select the **Market** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Real Time Balancing Market**.
5. Select **LMP Summary**.
6. Select an hour.
7. Choose an interval, and select **View**.
Query Real-Time MCP Summary by Reserve Zone

To view Real-Time MCP Summary by Reserve Zone:

1. Select the **Market** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Real Time Balancing Market**.
5. Select **MCP Summary**.
6. Select an hour.
7. Choose an interval, and select **View**.
Query Real-Time Regulation Status by Asset Owner

To view Real-Time Regulation Status by Asset Owner:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Market Results.
5. Select Real Time Dispatch.
6. Choose Real Time Regulation Status, and select View.

Query Real-Time Regulation Status by Resource

To view Real-Time Regulation Status by Resource:

1. Select the Resource Offers tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select Resources.
5. Select a resource.
6. Select Real Time Results.
7. Choose Real Time Regulation Status, and select View.
Query Real-Time VRLs

To view Real-Time VRLs:

1. Select the **Market** tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Select **Real Time Balancing Market**.
5. Select **Violation Relaxation Limits**.
6. Select an hour.
7. Choose an interval, and select **View**.
Administration

XML Upload
(Functionality is not yet implemented in the UI)

Update XML Notification Listener URLs
(Functionality is not yet implemented in the UI)

**Note**: To add or modify XML listeners with the Markets system, please submit a request via the Request Management System (RMS). SPP will register listeners on the MPs behalf until this page is developed.

Query XML Notification Listener URLs
(Functionality is not yet implemented in the UI)
Transaction Log

Query Markets Transaction Log

To view Markets Transaction Log:

1. Select the Transaction Log tab.
2. In the Navigation tree, select the appropriate Asset Owner.
3. Select a date.
4. Choose Transactions, and select View.

5. In the Transaction Details column, choose Download to download the details associated with the transaction.